SGS System Partial Outage

Incident Report for chambercustoms

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 11:25 GMT

Identified

We are currently investigating a partial outage on SGS eGTA that is affecting Declaration Submissions. CDS Declarations are now going through again but ENS Declarations are still down.

Please hold submitting ENS Declarations until this has been resolved.

ChamberCustoms Team
Posted Mar 05, 2026 - 10:48 GMT
This incident affected: ChamberCustoms Systems (ENS (Import Safety and Security) Declarations (SGS)).